找回密码
 注册帐号

扫一扫,访问微社区

其他 unity发布webgl文件打开后屏幕一片粉色

8
回复
91
查看
打印 上一主题 下一主题
[ 复制链接 ]

2

主题

9

帖子

27

积分

Rank: 1

UID
326205
好友
0
蛮牛币
7
威望
0
注册时间
2019-7-2
在线时间
16 小时
最后登录
2019-7-17
5蛮牛币
如题,以为是内存太小,打包最大内存试过了还是这样,其他的几个项目打包过都没有这个问题。都是可以正常运行的。


回复

使用道具 举报

5熟悉之中
585/1000
排名
5142
昨日变化

2

主题

46

帖子

585

积分

Rank: 5Rank: 5

UID
185612
好友
0
蛮牛币
813
威望
0
注册时间
2016-11-21
在线时间
257 小时
最后登录
2019-7-12
沙发
2019-7-10 10:57:23 只看该作者
很明显是材质丢失,是否使用了AB包,现在AB包不在打包Shader,需要手动配置
回复

使用道具 举报

3偶尔光临
251/300
排名
11659
昨日变化

2

主题

29

帖子

251

积分

Rank: 3Rank: 3Rank: 3

UID
306526
好友
1
蛮牛币
223
威望
0
注册时间
2018-11-30
在线时间
136 小时
最后登录
2019-7-17
板凳
2019-7-10 11:43:43 只看该作者
可能是你天空盒子的问题吧。
回复

使用道具 举报

4四处流浪
300/500
排名
12882
昨日变化

0

主题

83

帖子

300

积分

Rank: 4

UID
165167
好友
1
蛮牛币
1705
威望
0
注册时间
2016-8-31
在线时间
141 小时
最后登录
2019-7-18
QQ
地板
2019-7-10 12:43:34 只看该作者
明显是模型的材质都丢了
回复

使用道具 举报

2

主题

9

帖子

27

积分

Rank: 1

UID
326205
好友
0
蛮牛币
7
威望
0
注册时间
2019-7-2
在线时间
16 小时
最后登录
2019-7-17
5#
楼主 2019-7-10 13:49:19 只看该作者
13940377669 发表于 2019-7-10 12:43
明显是模型的材质都丢了

那要换掉材质么?
回复

使用道具 举报

2

主题

9

帖子

27

积分

Rank: 1

UID
326205
好友
0
蛮牛币
7
威望
0
注册时间
2019-7-2
在线时间
16 小时
最后登录
2019-7-17
6#
楼主 2019-7-10 13:50:21 只看该作者
ljh77889 发表于 2019-7-10 11:43
可能是你天空盒子的问题吧。

没有用到天空盒。
回复

使用道具 举报

2

主题

9

帖子

27

积分

Rank: 1

UID
326205
好友
0
蛮牛币
7
威望
0
注册时间
2019-7-2
在线时间
16 小时
最后登录
2019-7-17
7#
楼主 2019-7-10 16:13:34 只看该作者
已经解决,参考https://www.cnblogs.com/zs3718/p/10643349.html
需要自己写代码把非内置的、用到的shader添加到Project Settings - Graphics - Always Included Shaders里,不然启动游戏后会满屏粉红色。
回复

使用道具 举报

排名
64931
昨日变化

0

主题

6

帖子

60

积分

Rank: 2Rank: 2

UID
297049
好友
1
蛮牛币
247
威望
0
注册时间
2018-9-14
在线时间
52 小时
最后登录
2019-7-18
8#
7 天前 只看该作者
用过shader嘛,是不是有些不支持webgl
回复

使用道具 举报

排名
64931
昨日变化

0

主题

6

帖子

60

积分

Rank: 2Rank: 2

UID
297049
好友
1
蛮牛币
247
威望
0
注册时间
2018-9-14
在线时间
52 小时
最后登录
2019-7-18
9#
7 天前 只看该作者
shader的问题,有些shader不支持webgl
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册帐号

本版积分规则